<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Travis Grimler" />
<meta property="news_keywords" content="sports,Backus Wolverines, Micah Eveland, Foothills Christian Academy, Bob Nelson, Pequot Lakes Indians, Isaac Krecklau" />
<meta property="description" content="For the first time in 27 years the Backus gym hosted a Backus Wolverines game on Feb. 17.This is the second time the Wolverines faced off against the Lake Region..." />
<meta property="keywords" content="sports,Backus Wolverines, Micah Eveland, Foothills Christian Academy, Bob Nelson, Pequot Lakes Indians, Isaac Krecklau" />
<meta property="article:publisher" content="https://www.facebook.com/pineandlakesecho" />
<meta property="article:tag" content="sports,Backus Wolverines, Micah Eveland, Foothills Christian Academy, Bob Nelson, Pequot Lakes Indians, Isaac Krecklau" />
<meta property="article:published_time" content="2017-02-24T00:16:18-06:00" />
<meta property="image:alt" content="Lena Richards/Echo Journal Correspondent Isaac Krecklau had Wolverine fans on the edge of their seats during their first Feb. 17 home game when he tied the game in the final minutes. Lake Region Christian School came back and beat the Wolverines 51 to 45 before time ran out." />
<meta property="article:modified_time" content="2017-02-24T00:16:18-06:00" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="Wolverines play hard in first home game in 27 years" />
<meta property="twitter:image" content="http://www.pineandlakes.com/sites/default/files/styles/16x9_430/public/fieldimages/43/0224/0b3axyh3ek8hfcw5dzhpswlpyr1k.jpg?itok=xcG8X7gu" />
<meta property="twitter:url" content="http://www.pineandlakes.com/sports/4224083-wolverines-play-hard-first-home-game-27-years" />
<meta property="article:author" content="http://facebook.com/PEJTravis" />
<meta property="image:title" content="Lena Richards/Echo Journal Correspondent Isaac Krecklau had Wolverine fans on the edge of their seats during their first Feb. 17 home game when he tied the game in the final minutes. Lake Region Christian School came back and beat the Wolverines 51 to 45 before time ran out." />
<meta property="twitter:description" content="For the first time in 27 years the Backus gym hosted a Backus Wolverines game on Feb. 17.This is the second time the Wolverines faced off against the Lake Region Christian School from Baxter in a non conference game, but the first home game for the Foothills Christian Academy team. Coach Micah Eveland..." />
<meta property="og:type" content="article" />
<meta property="og:description" content="For the first time in 27 years the Backus gym hosted a Backus Wolverines game on Feb. 17.This is the second time the Wolverines faced off against the Lake Region Christian School from Baxter in a non conference game, but the first home game for the Foothills Christian Academy team. Coach Micah Eveland..." />
<meta property="og:url" content="http://www.pineandlakes.com/sports/4224083-wolverines-play-hard-first-home-game-27-years" />
<meta property="og:image:width" content="300" />
<meta property="og:image" content="http://www.pineandlakes.com/sites/default/files/styles/square_300/public/fieldimages/43/0224/0b3axyh3ek8hfcw5dzhpswlpyr1k.jpg?itok=5r-Dow5q" />
<meta property="og:image:height" content="300" />
<meta property="og:title" content="Wolverines play hard in first home game in 27 years" />
<link rel="shortcut icon" href="http://www.pineandlakes.com/sites/all/themes/pineandlakes_theme/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="http://www.pineandlakes.com/sites/all/themes/pineandlakes_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="amphtml" href="http://www.pineandlakes.com/sports/4224083-wolverines-play-hard-first-home-game-27-years?amp" />
<link rel="shortlink" href="/node/4224083" />
<link rel="canonical" href="/sports/4224083-wolverines-play-hard-first-home-game-27-years" />
    <title>Wolverines play hard in first home game in 27 years | Pineandlakes Echo Journal</title>
    <link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.2/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/css/article-slider.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/all/themes/pineandlakes_theme/css/global-no-mqs.css?olvoae" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/all/themes/pineandlakes_theme/css/global.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.pineandlakes.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-3226552-20', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.2/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?olvoae"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?olvoae"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-PineAndLakes"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

            if (jQuery(window).width() >= 728) {
              jQuery.getScript('//biddr.brealtime.com/49170050-648.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/49170050-648.js');
              });
            } else {
              jQuery.getScript('//biddr.brealtime.com/91130429-649.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/91130429-649.js');
              });
            }
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4224083 node-type-article domain-www-pineandlakes-com context-sports"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Pineandlakes Echo Journal"><img src="http://www.pineandlakes.com/sites/all/themes/pineandlakes_theme/logo.png" alt="Pineandlakes Echo Journal" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Pineandlakes Echo Journal</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/sports/4224083-wolverines-play-hard-first-home-game-27-years" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4224086-seasonal-load-restrictions-announced'>Seasonal load restrictions announced</a></li><li><a href='/news/4224085-older-americans-act-funds-aid-seniors-area-counties'>Older Americans Act funds to aid seniors in area counties</a></li><li><a href='/news/4224081-nisswa-council-gives-ok-dynamic-display-signs-highway-business-district-only'>Nisswa: Council gives OK for dynamic display signs - in highway business district only</a></li><li><a href='/news/4224080-vehicle-traffic-be-restricted-eelpout-festival'>Vehicle traffic to be restricted for Eelpout Festival</a></li><li><a href='/news/4224079-cass-county-warm-weather-leads-poor-conditions-area-lakes'>Cass County: Warm weather leads to poor conditions on area lakes</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/business" target="_self">business</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/state" target="_self">state</a></li><li><a href="/news/regional" target="_self">regional</a></li><li><a href="/news/legals" target="_self">legals</a></li><li><a href="/basic-page/3719561-distribution-map" target="_self">Distribution Map</a></li><li><a href="/basic-page/3719570-2015-advertising-rates" target="_self">Advertising Rates</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/4224094-stone-8th-state-meet-mcguire-46th-biwabik'>Stone 8th in state meet - McGuire 46th in Biwabik</a></li><li><a href='/sports/4224083-wolverines-play-hard-first-home-game-27-years'>Wolverines play hard in first home game in 27 years</a></li><li><a href='/sports/4223997-rubio-stay-put-timberwolves'>Rubio to stay put with Timberwolves</a></li><li><a href='/sports/4223988-lightning-boys-fall-section-quarterfinals'>Lightning boys fall in section quarterfinals</a></li><li><a href='/sports/4223720-minnesota-twins-relief-pitcher-admits-vomiting-nearly-every-time-taking-mound'>Minnesota Twins relief pitcher admits to vomiting nearly every time before taking the mound</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/outdoors" target="_self">outdoors</a></li><li><a href="/basic-page/3728676-northland-outdoors" target="_self">Northland Outdoors</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4223979-leroy-rieke'>Leroy Rieke</a></li><li><a href='/obituaries/4223262-janet-moen'>Janet Moen</a></li><li><a href='/obituaries/4221275-elaine-lefebvre'>Elaine LeFebvre</a></li><li><a href='/obituaries/4223263-doris-kelley-thiessen'>Doris Kelley-Thiessen</a></li><li><a href='/obituaries/4223265-eloise-kay-jans'>Eloise Kay Jans</a></li></ul></div></div></li><li class='leaf'><a href="/lifestyles" target="_self">lifestyles</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/lifestyles/entertainment/4224091-reminders-feb-23-2017'>Reminders-Feb. 23, 2017</a></li><li><a href='/lifestyles/entertainment/4224087-calendar-events-feb-24-2017'>Calendar of Events-Feb. 24, 2017</a></li><li><a href='/lifestyles/4223328-card-games-feb-23-2017'>Card games: Feb. 23, 2017</a></li><li><a href='/lifestyles/4223326-pages-past-feb-23-2017'>Pages from the Past - Feb. 23, 2017</a></li><li><a href='/lifestyles/features/4223324-nisswa-winter-jubilee-warm-successful'>Nisswa Winter Jubilee warm, but successful</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/lifestyles/arts" target="_self">arts</a></li><li><a href="/lifestyles/entertainment" target="_self">entertainment</a></li><li><a href="/lifestyles/faces" target="_self">faces</a></li><li><a href="/lifestyles/features" target="_self">features</a></li><li><a href="/lifestyles/recipes" target="_self">recipes</a></li><li><a href="/lifestyles/tech" target="_self">tech</a></li><li><a href="/basic-page/3712660-weddings-north-2015" target="_self">Weddings North</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/letters-editor/4223318-letter-editor-columnist-discovers-universal-theory-everything'>Letter to the Editor: Columnist discovers universal theory of everything</a></li><li><a href='/opinion/columns/4222586-cracker-barrel-paying-attention'>The Cracker Barrel: Paying attention</a></li><li><a href='/opinion/columns/4221421-parenting-perspectives-let-your-kids-choose-or-pave-their-own-paths'>Parenting Perspectives: Let your kids choose -- or pave -- their own paths</a></li><li><a href='/opinion/columns/4221835-last-windrow-ideas-minnesotas-super-bowl-visitors'>The Last Windrow: Ideas for Minnesota&#039;s Super Bowl visitors</a></li><li><a href='/opinion/columns/4220333-column-dont-blame-your-pain-weather'>Column: Don&#039;t blame your pain on the weather</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/letters-editor" target="_self">letters to the editor</a></li><li><a href="/opinion/columns" target="_self">columns</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/4220861-wedding-announced-denny-dj-pink-and-martha-worms'>Wedding Announced: Denny (DJ) Pink and Martha Worms</a></li><li><a href='/milestones/4220860-65th-wedding-anniversary-don-and-kathy-obrien'>65th Wedding Anniversary: Don and Kathy O&#039;Brien</a></li><li><a href='/milestones/4220859-90th-birthday-rachel-wing'>90th Birthday: Rachel Wing</a></li><li><a href='/milestones/4220858-95th-birthday-ralph-yeager'>95th Birthday: Ralph Yeager</a></li><li><a href='/milestones/4220857-4-generations-jensen-stanwood-nelson'>4 Generations: Jensen, Stanwood, Nelson</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/births" target="_self">births</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/content/e-edition" target="_self">e-edition</a></li><li class='leaf no-doormat'><a href="http://pineandlakes.mycapture.com/mycapture/index.asp" target="_self">KLICK</a></li><li class='leaf no-doormat'><a href="/basic-page/3765210-extra" target="_self">extra</a></li><li class='leaf no-doormat'><a href="http://www3.forumnewspaper.com/Olive/ODN/BDES.1.4/" target="_self">SHOPPER</a></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="sports "> <meta itemprop='dateline' content=", "> <meta itemprop='articleBody' content="&lt;p&gt;For the first time in 27 years the Backus gym hosted a Backus Wolverines game on Feb. 17.&lt;/p&gt;&lt;p&gt;This is the second time the Wolverines faced off against the Lake Region Christian School from Baxter in a non conference game, but the first home game for the Foothills Christian Academy team. Coach Micah Eveland said his team kept on Lake Region's tail throughout most of the game, showing improvement over the last game in Baxter.&lt;/p&gt;&lt;p&gt;&quot;They started making their layups and the shots they should make,&quot; Eveland said. &quot;They got it figured out that if they execute their plays they get easier shots.&quot;&lt;/p&gt;&lt;p&gt;Team members said the team ran drills on layups and boxing out to prepare for the rematch, and the practice resulted in at least a few close moments, including near the end of the game.&lt;/p&gt;&lt;p&gt;&quot;Isaac Krecklau made a three pointer that tied the game up in the last couple of minutes,&quot; Eveland said. &quot;It was a close game the whole time really.&quot;&lt;/p&gt;&lt;p&gt;Eveland said the team's greatest weakness was in defense, something which the fledgeling team will have to work on if they continue again in the 2017-2018 season, though the very existence of the team depends on the students themselves.&lt;/p&gt;&lt;p&gt;&quot;As small numbers as they have it depends on how many kids they can get and what all goes on there,&quot; Eveland said.&lt;/p&gt;&lt;p&gt;The last Wolverine home game was also a close one which was won by a last minute basket.&lt;/p&gt;&lt;p&gt;March 1 of 1990 was the last hurrah of the original Backus Wolverines, and according to an article by Wayne Wallin in the Pine River Journal they went out with a fight.&lt;/p&gt;&lt;p&gt;Coach Bob Nelson led the eighth seeded Wolverines against the Pequot Lakes Indians in the District 24 boys' basketball tournament. Nelson was a relatively new coach, having started in 1979, but he found the small team was tenacious.&lt;/p&gt;&lt;p&gt;&quot;That was my first coaching job,&quot; Nelson said in a phone interview. &quot;It was kind of new to me starting out, but coaching a small school like that you don't have a whole lot of people to choose from. A lot of times you might have seniors, juniors and a sophomore or something like that. Sometimes you have younger kids play. You have to use just about everybody you have. The schools you played were small schools too. It was challenging but enjoyable. It seemed like they always played hard. I think you have to to compete hard, especially playing against bigger schools like Pine River and Pequot Lakes.&quot;&lt;/p&gt;&lt;p&gt;It was a home game and though Jason Marcum with Pequot Lakes nearly cost them the victory, three pointers by senior Kyle Haddix literally in the last second of the game won the game 67-64.&lt;/p&gt;&lt;p&gt;Haddix was just short of his 1,000 career points in the 89-90 season and was ultimately named the conference's most valued player.&lt;/p&gt;&lt;p&gt;The return of the Wolverines was a topic of pride for many locals, including members of Backus' last graduating class. Some of them were visible in the cheering section wearing old purple and gold Wolverines Jerseys or letter jackets. For the current and former coaches it was also a treat.&lt;/p&gt;&lt;p&gt;&quot;It feels good,&quot; Eveland said. &quot;It's kind of an honor. I went to grade school there as well and we played there in grade school. We came back to Backus when I was in high school as well.&quot;&lt;/p&gt;&lt;p&gt;&quot;I had always enjoyed that name,&quot; Nelson said. &quot;I liked it and I hope they have a good time with it.&quot;&lt;/p&gt;&lt;p&gt;The Wolverines team name was reclaimed by Clayton Borman (15) and Krecklau (16) when they found that Minnesota High School League rules did not allow them to enter athletic teams with the nearby Pine River-Backus Tigers. They lead the charge which resulted in the creation of the team and the short non conference season this year.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Wolverines play hard in first home game in 27 years"> <meta itemprop='author' content="Travis Grimler"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-02-24T00:16:18"> <meta itemprop='dateModified' content="2017-02-24T00:16:18"> <link itemprop='mainEntityOfPage' content="node/4224083"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.pineandlakes.com/sites/default/files/styles/square_300/public/fieldimages/43/0224/0b3axyh3ek8hfcw5dzhpswlpyr1k.jpg?itok=5r-Dow5q"> <meta itemprop="width" content="4000"> <meta itemprop="height" content="6000"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Travis Grimler"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Wolverines play hard in first home game in 27 years "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content=""> <meta itemprop='addressRegion' content=""> <meta itemprop='streetAddress' content=""> <meta itemprop='postalCode' content=""> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>Wolverines play hard in first home game in 27 years</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/travis-grimler'>Travis Grimler</a></span>
  <span class='node-byline-time'> Today  at 12:16 a.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'><img class='node-image large' src='http://www.pineandlakes.com/sites/default/files/styles/16x9_620/public/fieldimages/43/0224/0b3axyh3ek8hfcw5dzhpswlpyr1k.jpg?itok=i71m4NKD' data-featherlight='http://www.pineandlakes.com/sites/default/files/styles/full_1000/public/fieldimages/43/0224/0b3axyh3ek8hfcw5dzhpswlpyr1k.jpg?itok=6Dp-iHZC'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lena Richards/Echo Journal Correspondent Isaac Krecklau had Wolverine fans on the edge of their seats during their first Feb. 17 home game when he tied the game in the final minutes. Lake Region Christian School came back and beat the Wolverines 51 to 45 before time ran out.</span><span class='slide-number'>1 / 3</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.pineandlakes.com/sites/default/files/styles/16x9_620/public/fieldimages/43/0224/0b3axyh3ek8hfrgi1mdlszmz4dtq.jpg?itok=pW0FigNJ' data-featherlight='http://www.pineandlakes.com/sites/default/files/styles/full_1000/public/fieldimages/43/0224/0b3axyh3ek8hfrgi1mdlszmz4dtq.jpg?itok=Jtj3oBJo'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lena Richards/Echo Journal Correspondent Old Letter Jackets and jerseys were visible in the crowd during the Wolverines&#039; Feb. 17 home game against Lake Region Christian School.</span><span class='slide-number'>2 / 3</span></div><div class='individual-slide individual-slide-3' style='position: relative;'><img class='node-image large' src='http://www.pineandlakes.com/sites/default/files/styles/16x9_620/public/fieldimages/43/0224/0b3axyh3ek8hfs0tcvuprde1zwhm.jpg?itok=eiwjGtYP' data-featherlight='http://www.pineandlakes.com/sites/default/files/styles/full_1000/public/fieldimages/43/0224/0b3axyh3ek8hfs0tcvuprde1zwhm.jpg?itok=zGJ0sBjn'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lena Richards/Echo Journal Correspondent James Tilbury works to shake off a defender at the first Wolverines home game in 27 years.</span><span class='slide-number'>3 / 3</span></div></div><div class='node-body'><p>For the first time in 27 years the Backus gym hosted a Backus Wolverines game on Feb. 17.</p></div><div class='node-body'><p>This is the second time the Wolverines faced off against the Lake Region Christian School from Baxter in a non conference game, but the first home game for the Foothills Christian Academy team. Coach Micah Eveland said his team kept on Lake Region's tail throughout most of the game, showing improvement over the last game in Baxter.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_7k7z2fpzdz6zd5ashtt4avetxi' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>"They started making their layups and the shots they should make," Eveland said. "They got it figured out that if they execute their plays they get easier shots."</p><p>Team members said the team ran drills on layups and boxing out to prepare for the rematch, and the practice resulted in at least a few close moments, including near the end of the game.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>"Isaac Krecklau made a three pointer that tied the game up in the last couple of minutes," Eveland said. "It was a close game the whole time really."</p><p>Eveland said the team's greatest weakness was in defense, something which the fledgeling team will have to work on if they continue again in the 2017-2018 season, though the very existence of the team depends on the students themselves.</p><p>"As small numbers as they have it depends on how many kids they can get and what all goes on there," Eveland said.</p><p>The last Wolverine home game was also a close one which was won by a last minute basket.</p><p>March 1 of 1990 was the last hurrah of the original Backus Wolverines, and according to an article by Wayne Wallin in the Pine River Journal they went out with a fight.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>Coach Bob Nelson led the eighth seeded Wolverines against the Pequot Lakes Indians in the District 24 boys' basketball tournament. Nelson was a relatively new coach, having started in 1979, but he found the small team was tenacious.</p><p>"That was my first coaching job," Nelson said in a phone interview. "It was kind of new to me starting out, but coaching a small school like that you don't have a whole lot of people to choose from. A lot of times you might have seniors, juniors and a sophomore or something like that. Sometimes you have younger kids play. You have to use just about everybody you have. The schools you played were small schools too. It was challenging but enjoyable. It seemed like they always played hard. I think you have to to compete hard, especially playing against bigger schools like Pine River and Pequot Lakes."</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>It was a home game and though Jason Marcum with Pequot Lakes nearly cost them the victory, three pointers by senior Kyle Haddix literally in the last second of the game won the game 67-64.</p><p>Haddix was just short of his 1,000 career points in the 89-90 season and was ultimately named the conference's most valued player.</p><p>The return of the Wolverines was a topic of pride for many locals, including members of Backus' last graduating class. Some of them were visible in the cheering section wearing old purple and gold Wolverines Jerseys or letter jackets. For the current and former coaches it was also a treat.</p><p>"It feels good," Eveland said. "It's kind of an honor. I went to grade school there as well and we played there in grade school. We came back to Backus when I was in high school as well."</p><p>"I had always enjoyed that name," Nelson said. "I liked it and I hope they have a good time with it."</p><p>The Wolverines team name was reclaimed by Clayton Borman (15) and Krecklau (16) when they found that Minnesota High School League rules did not allow them to enter athletic teams with the nearby Pine River-Backus Tigers. They lead the charge which resulted in the creation of the team and the short non conference season this year.</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.pineandlakes.com/taxonomy/term/21'>sports</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/372926'>Backus Wolverines</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/342669'>Micah Eveland</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/310456'>Foothills Christian Academy</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/237098'>Bob Nelson</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/303850'>Pequot Lakes Indians</a><a class='topic tag' href='http://www.pineandlakes.com/taxonomy/term/373888'>Isaac Krecklau</a></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',17);
  ga('send', 'event', 'article', 'paragraphs', '17');
  ga('send', 'event', 'article', 'length', 'characters',3707);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',30992);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',17);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '17');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',3707);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',30992);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/obituaries/3983325-deborah-j-traynor-grimler"><span class="number">1. </span>Deborah J. (Traynor) Grimler</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/4224080-vehicle-traffic-be-restricted-eelpout-festival"><span class="number">2. </span>Vehicle traffic to be restricted for Eelpout Festival</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/4223833-two-found-dead-house-fire-northwest-minnesota"><span class="number">3. </span>Two found dead in house fire in northwest Minnesota</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/4224081-nisswa-council-gives-ok-dynamic-display-signs-highway-business-district-only"><span class="number">4. </span>Nisswa: Council gives OK for dynamic display signs - in highway business district only</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/4224083-wolverines-play-hard-first-home-game-27-years"><span class="number">5. </span>Wolverines play hard in first home game in 27 years</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/sports/4224094-stone-8th-state-meet-mcguire-46th-biwabik">Stone 8th in state meet - McGuire 46th in Biwabik<span class='latest-date'>8 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/lifestyles/entertainment/4224091-reminders-feb-23-2017">Reminders-Feb. 23, 2017<span class='latest-date'>8 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/lifestyles/entertainment/4224087-calendar-events-feb-24-2017">Calendar of Events-Feb. 24, 2017<span class='latest-date'>8 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/4224086-seasonal-load-restrictions-announced">Seasonal load restrictions announced<span class='latest-date'>8 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4224085-older-americans-act-funds-aid-seniors-area-counties">Older Americans Act funds to aid seniors in area counties<span class='latest-date'>8 hours ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget odd block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget even block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
            <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
            <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
          </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://twitter.com/pal_echojournal" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/pineandlakesecho" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Pineandlakes Echo Journal</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Pineandlakes Echo Journal</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields"></div>
      <span class="locality"></span>, 
      <span class="region"></span> 
      <span class="postal-code"></span>
    </div>

    Call us at <div class="tel"></div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php" style="display: none;">randomness</a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=pineandlakes.com&tags=sports,Backus Wolverines, Micah Eveland, Foothills Christian Academy, Bob Nelson, Pequot Lakes Indians, Isaac Krecklau',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?olvoae"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?olvoae"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_fmp1S-5y78PyIlN6garUecXqzFXRTmkF862CNm-d-30.js"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?olvoae"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?olvoae"></script>
<script type="text/javascript" src="http://www.pineandlakes.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>